use strict;
my $str = '<div>
<span class=\'customer\' id=\'phone$0\'>Home</span>
<br/>
<span class=\'customer\' id=\'phone$1\'>Business</span>
<br/>
<span class=\'customer\' id=\'phone$2\'>Mobile</span>
</div>';
my $regex = qr/'.*?' id='phone\$1'>.*?</p;
my $subst = '\'customer\' id=\'phone\\$1\'>Organization<';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";