const regex = /'.*?' id='phone\$1'>.*?</g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'.*?\' id=\'phone\\$1\'>.*?<', 'g')
const str = `<div>
<span class='customer' id='phone\$0'>Home</span>
<br/>
<span class='customer' id='phone\$1'>Business</span>
<br/>
<span class='customer' id='phone\$2'>Mobile</span>
</div>`;
const subst = `'customer' id='phone\$1'>Organization<`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);