# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"'.*?' id='phone\$1'>.*?<"
test_str = ("<div>\n"
" <span class='customer' id='phone$0'>Home</span>\n"
"<br/>\n"
" <span class='customer' id='phone$1'>Business</span>\n"
"<br/>\n"
" <span class='customer' id='phone$2'>Mobile</span>\n"
"</div>")
subst = "'customer' id='phone\\$1'>Organization<"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.