import Foundation
let pattern = #"'.*?' id='phone\$1'>.*?<"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div>
<span class='customer' id='phone$0'>Home</span>
<br/>
<span class='customer' id='phone$1'>Business</span>
<br/>
<span class='customer' id='phone$2'>Mobile</span>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'customer' id='phone\$1'>Organization<"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)