re = /'.*?' id='phone\$1'>.*?</
str = '<div>
<span class=\'customer\' id=\'phone$0\'>Home</span>
<br/>
<span class=\'customer\' id=\'phone$1\'>Business</span>
<br/>
<span class=\'customer\' id=\'phone$2\'>Mobile</span>
</div>'
subst = '\'customer\' id=\'phone\\$1\'>Organization<'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result