using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'.*?' id='phone\$1'>.*?<";
string substitution = @"'customer' id='phone\$1'>Organization<";
string input = @"<div>
<span class='customer' id='phone$0'>Home</span>
<br/>
<span class='customer' id='phone$1'>Business</span>
<br/>
<span class='customer' id='phone$2'>Mobile</span>
</div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}