package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'.*?' id='phone\$1'>.*?<`)
var str = `<div>
<span class='customer' id='phone$0'>Home</span>
<br/>
<span class='customer' id='phone$1'>Business</span>
<br/>
<span class='customer' id='phone$2'>Mobile</span>
</div>`
var substitution = "'customer' id='phone\$1'>Organization<"
fmt.Println(re.ReplaceAllString(str, substitution))
}