import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'.*?' id='phone\\$1'>.*?<";
final String string = "<div>\n"
+ " <span class='customer' id='phone$0'>Home</span>\n"
+ "<br/>\n"
+ " <span class='customer' id='phone$1'>Business</span>\n"
+ "<br/>\n"
+ " <span class='customer' id='phone$2'>Mobile</span>\n"
+ "</div>";
final String subst = "'customer' id='phone\\$1'>Organization<";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}