package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*(:2(\[(((\d*,){3})\]))).*`)
var str = `:1[2,2,2,]:2[0,14,88,]:homebase[7,4,1776,]:`
var substitution = "$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}