import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(:2(\\[(((\\d*,){3})\\]))).*";
final String string = ":1[2,2,2,]:2[0,14,88,]:homebase[7,4,1776,]:";
final String subst = "$4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}