import re
regex = re.compile(r".*(:2(\[(((\d*,){3})\]))).*")
test_str = ":1[2,2,2,]:2[0,14,88,]:homebase[7,4,1776,]:"
subst = "$4"
result = regex.sub(subst, test_str)
if result:
print(result)