// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*(:2(\[(((\d*,){3})\]))).*").unwrap();
let string = ":1[2,2,2,]:2[0,14,88,]:homebase[7,4,1776,]:";
let substitution = "$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}