$re = '/.*(:2(\[(((\d*,){3})\]))).*/';
$str = ':1[2,2,2,]:2[0,14,88,]:homebase[7,4,1776,]:';
$subst = "$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;