use strict;
my $str = ':1[2,2,2,]:2[0,14,88,]:homebase[7,4,1776,]:';
my $regex = qr/.*(:2(\[(((\d*,){3})\]))).*/p;
my $subst = '$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";