using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((<ns3:[a-z,0-9]+>)\{(fn:data(\(\$[a-z,0-9./,:]+\)))\}</ns3:[a-z,0-9]+>)";
string substitution = @"{if($3)then$1else if($4)then$2else()}";
string input = @"{
""name"": ""Apostol"",
""steam"": 76561198017242084
},";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}