$re = '/((<ns3:[a-z,0-9]+>)\{(fn:data(\(\$[a-z,0-9./,:]+\)))\}</ns3:[a-z,0-9]+>)/';
$str = '{
"name": "Apostol",
"steam": 76561198017242084
},';
$subst = "{if($3)then$1else if($4)then$2else()}";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;