package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((<ns3:[a-z,0-9]+>)\{(fn:data(\(\$[a-z,0-9./,:]+\)))\}</ns3:[a-z,0-9]+>)`)
var str = []byte(`{
"name": "Apostol",
"steam": 76561198017242084
},`)
var substitution = []byte("{if($3)then$1else if($4)then$2else()}")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}