import Foundation
let pattern = #"((<ns3:[a-z,0-9]+>)\{(fn:data(\(\$[a-z,0-9./,:]+\)))\}</ns3:[a-z,0-9]+>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"name": "Apostol",
"steam": 76561198017242084
},
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{if($3)then$1else if($4)then$2else()}"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}