# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((<ns3:[a-z,0-9]+>)\{(fn:data(\(\$[a-z,0-9./,:]+\)))\}</ns3:[a-z,0-9]+>)"
test_str = ("{\n"
" \"name\": \"Apostol\",\n"
" \"steam\": 76561198017242084\n"
" },")
subst = "{if($3)then$1else if($4)then$2else()}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.