use strict;
my $str = '{
"name": "Apostol",
"steam": 76561198017242084
},';
my $regex = qr/((<ns3:[a-z,0-9]+>)\{(fn:data(\(\$[a-z,0-9./,:]+\)))\}</ns3:[a-z,0-9]+>)/p;
my $subst = '{if($3)then$1else if($4)then$2else()}';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";