re = /((<ns3:[a-z,0-9]+>)\{(fn:data(\(\$[a-z,0-9.\/,:]+\)))\}<\/ns3:[a-z,0-9]+>)/
str = '{
"name": "Apostol",
"steam": 76561198017242084
},'
subst = '{if($3)then$1else if($4)then$2else()}'
result = str.sub(re, subst)
# Print the result of the substitution
puts result