const regex = /((<ns3:[a-z,0-9]+>)\{(fn:data(\(\$[a-z,0-9./,:]+\)))\}</ns3:[a-z,0-9]+>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((<ns3:[a-z,0-9]+>)\\{(fn:data(\\(\\$[a-z,0-9.\/,:]+\\)))\\}<\/ns3:[a-z,0-9]+>)', '')
const str = `{
"name": "Apostol",
"steam": 76561198017242084
},`;
const subst = `{if($3)then$1else if($4)then$2else()}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);