// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((<ns3:[a-z,0-9]+>)\{(fn:data(\(\$[a-z,0-9./,:]+\)))\}</ns3:[a-z,0-9]+>)").unwrap();
let string = "{
\"name\": \"Apostol\",
\"steam\": 76561198017242084
},";
let substitution = "{if($3)then$1else if($4)then$2else()}";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}