using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w]+)([, ])+(Democratic.+|Republic.+)";
string substitution = @"$3 $1";
string input = @"Congo, Republic of
Congo, Democratic Republic of
Tunisia
Prague
Sail, Republic
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}