$re = '/([\w]+)([, ])+(Democratic.+|Republic.+)/i';
$str = 'Congo, Republic of
Congo, Democratic Republic of
Tunisia
Prague
Sail, Republic
';
$subst = "$3 $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;