package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([\w]+)([, ])+(Democratic.+|Republic.+)`)
var str = `Congo, Republic of
Congo, Democratic Republic of
Tunisia
Prague
Sail, Republic
`
var substitution = "$3 $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}