re = /([\w]+)([, ])+(Democratic.+|Republic.+)/i
str = 'Congo, Republic of
Congo, Democratic Republic of
Tunisia
Prague
Sail, Republic
'
subst = '$3 $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result