import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w]+)([, ])+(Democratic.+|Republic.+)";
final String string = "Congo, Republic of\n"
+ "Congo, Democratic Republic of\n"
+ "Tunisia\n"
+ "Prague\n"
+ "Sail, Republic\n\n\n\n\n\n\n\n\n\n\n\n";
final String subst = "$3 $1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}