const regex = /([\w]+)([, ])+(Democratic.+|Republic.+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w]+)([, ])+(Democratic.+|Republic.+)', 'gi')
const str = `Congo, Republic of
Congo, Democratic Republic of
Tunisia
Prague
Sail, Republic
`;
const subst = `$3 $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);