// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([\w]+)([, ])+(Democratic.+|Republic.+)").unwrap();
let string = "Congo, Republic of
Congo, Democratic Republic of
Tunisia
Prague
Sail, Republic
";
let substitution = "$3 $1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}