use strict;
my $str = 'Congo, Republic of
Congo, Democratic Republic of
Tunisia
Prague
Sail, Republic
';
my $regex = qr/([\w]+)([, ])+(Democratic.+|Republic.+)/ip;
my $subst = '$3 $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";