import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"accessRights\":\\s*\"[0-9,a-f,A-F]{5}\"";
final String string = "{\n"
+ " \"users\": {\n"
+ " \"accessRights\":\"FFFFF\",\n"
+ " \"name\": \"admin\"\n"
+ " }\n"
+ "}";
final String subst = "\"accessRights\":\"abcde\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}