import re
regex = re.compile(r"\"accessRights\":\s*\"[0-9,a-f,A-F]{5}\"", flags=re.MULTILINE)
test_str = ("{\n"
" \"users\": {\n"
" \"accessRights\":\"FFFFF\",\n"
" \"name\": \"admin\"\n"
" }\n"
"}")
subst = "\"accessRights\":\"abcde\""
result = regex.sub(subst, test_str)
if result:
print(result)