use strict;
my $str = '{
"users": {
"accessRights":"FFFFF",
"name": "admin"
}
}';
my $regex = qr/"accessRights":\s*"[0-9,a-f,A-F]{5}"/mp;
my $subst = '"accessRights":"abcde"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";