re = /"accessRights":\s*"[0-9,a-f,A-F]{5}"/m
str = '{
"users": {
"accessRights":"FFFFF",
"name": "admin"
}
}'
subst = '"accessRights":"abcde"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result