// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"accessRights":\s*"[0-9,a-f,A-F]{5}""#).unwrap();
let string = "{
\"users\": {
\"accessRights\":\"FFFFF\",
\"name\": \"admin\"
}
}";
let substitution = "\"accessRights\":\"abcde\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}