# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(x=|y=)\"\s*([-]?[0-9]+)\s*\"/\1"\2\*factor"/gm;t' <<< "<polygon>
<vertex x=\"-15\" y=\"15\"/>
<vertex x=\"-15\" y=\"-15\"/>
</polygon>
<polygon>
<vertex x=\"15\" y=\"-15\"/>
<vertex x=\"15\" y=\"15\"/>
</polygon>
<polygon>
<vertex x=\"-15\" y=\"-15\"/>
<vertex x=\"15\" y=\"-15\"/>
</polygon>"