import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(x=|y=)\\\"\\s*([-]?[0-9]+)\\s*\\\"";
final String string = "<polygon>\n"
+ " <vertex x=\"-15\" y=\"15\"/>\n"
+ " <vertex x=\"-15\" y=\"-15\"/>\n"
+ "</polygon>\n"
+ "<polygon>\n"
+ " <vertex x=\"15\" y=\"-15\"/>\n"
+ " <vertex x=\"15\" y=\"15\"/>\n"
+ "</polygon>\n"
+ "<polygon>\n"
+ " <vertex x=\"-15\" y=\"-15\"/>\n"
+ " <vertex x=\"15\" y=\"-15\"/>\n"
+ "</polygon>";
final String subst = "\\1\"\\2\\*factor\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}