$re = '/(x=|y=)\"\s*([-]?[0-9]+)\s*\"/m';
$str = '<polygon>
<vertex x="-15" y="15"/>
<vertex x="-15" y="-15"/>
</polygon>
<polygon>
<vertex x="15" y="-15"/>
<vertex x="15" y="15"/>
</polygon>
<polygon>
<vertex x="-15" y="-15"/>
<vertex x="15" y="-15"/>
</polygon>';
$subst = "\1\"\2\*factor\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;