package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(x=|y=)\"\s*([-]?[0-9]+)\s*\"`)
var str = `<polygon>
<vertex x="-15" y="15"/>
<vertex x="-15" y="-15"/>
</polygon>
<polygon>
<vertex x="15" y="-15"/>
<vertex x="15" y="15"/>
</polygon>
<polygon>
<vertex x="-15" y="-15"/>
<vertex x="15" y="-15"/>
</polygon>`
var substitution = "\1"\2\*factor""
fmt.Println(re.ReplaceAllString(str, substitution))
}