const regex = new RegExp('(x=|y=)\\"\\s*([-]?[0-9]+)\\s*\\"', 'gm')
const str = `<polygon>
<vertex x="-15" y="15"/>
<vertex x="-15" y="-15"/>
</polygon>
<polygon>
<vertex x="15" y="-15"/>
<vertex x="15" y="15"/>
</polygon>
<polygon>
<vertex x="-15" y="-15"/>
<vertex x="15" y="-15"/>
</polygon>`;
const subst = `\1"\2\*factor"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);