use strict;
my $str = '<polygon>
<vertex x="-15" y="15"/>
<vertex x="-15" y="-15"/>
</polygon>
<polygon>
<vertex x="15" y="-15"/>
<vertex x="15" y="15"/>
</polygon>
<polygon>
<vertex x="-15" y="-15"/>
<vertex x="15" y="-15"/>
</polygon>';
my $regex = qr/(x=|y=)\"\s*([-]?[0-9]+)\s*\"/mp;
my $subst = '\\1"\\2\\*factor"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";