#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(x=|y=)\"\s*([-]?[0-9]+)\s*\""
Local $sString = "<polygon>" & @CRLF & _
" <vertex x="-15" y="15"/>" & @CRLF & _
" <vertex x="-15" y="-15"/>" & @CRLF & _
"</polygon>" & @CRLF & _
"<polygon>" & @CRLF & _
" <vertex x="15" y="-15"/>" & @CRLF & _
" <vertex x="15" y="15"/>" & @CRLF & _
"</polygon>" & @CRLF & _
"<polygon>" & @CRLF & _
" <vertex x="-15" y="-15"/>" & @CRLF & _
" <vertex x="15" y="-15"/>" & @CRLF & _
"</polygon>"
Local $sSubst = "\1"\2\*factor""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)