using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(x=|y=)\""\s*([-]?[0-9]+)\s*\""";
string substitution = @"\1""\2\*factor""";
string input = @"<polygon>
<vertex x=""-15"" y=""15""/>
<vertex x=""-15"" y=""-15""/>
</polygon>
<polygon>
<vertex x=""15"" y=""-15""/>
<vertex x=""15"" y=""15""/>
</polygon>
<polygon>
<vertex x=""-15"" y=""-15""/>
<vertex x=""15"" y=""-15""/>
</polygon>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}