import re
regex = re.compile(r"(x=|y=)\"\s*([-]?[0-9]+)\s*\"", flags=re.MULTILINE)
test_str = ("<polygon>\n"
" <vertex x=\"-15\" y=\"15\"/>\n"
" <vertex x=\"-15\" y=\"-15\"/>\n"
"</polygon>\n"
"<polygon>\n"
" <vertex x=\"15\" y=\"-15\"/>\n"
" <vertex x=\"15\" y=\"15\"/>\n"
"</polygon>\n"
"<polygon>\n"
" <vertex x=\"-15\" y=\"-15\"/>\n"
" <vertex x=\"15\" y=\"-15\"/>\n"
"</polygon>")
subst = "\\1\"\\2\\*factor\""
result = regex.sub(subst, test_str)
if result:
print(result)