# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{#val#}|([!-\\/:-@[-`{-~])/.{0,5}/gi;t' <<< "Hi {#VAL#}, Thank you {#val#}{#val#} for &visting us!"