re = /{#val#}|([!-\/:-@[-`{-~])/i
str = 'Hi {#VAL#}, Thank you {#val#}{#val#} for &visting us!'
subst = '.{0,5}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result