use strict;
my $str = 'Hi {#VAL#}, Thank you {#val#}{#val#} for &visting us!';
my $regex = qr/{#val#}|([!-\/:-@[-`{-~])/ip;
my $subst = '.{0,5}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";