import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{#val#\\}|([!-\\/:-@[-`\\{-~])";
final String string = "Hi {#VAL#}, Thank you {#val#}{#val#} for &visting us!";
final String subst = ".{0,5}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}