using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{#val#}|([!-\/:-@[-`{-~])";
string substitution = @".{0,5}";
string input = @"Hi {#VAL#}, Thank you {#val#}{#val#} for &visting us!";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}